Behaviors different between the data mapper and the generated application (.exe)
Problem reported by PHILIPPE GUITTARD - June 18 at 10:10 AM
Resolved
Hello,
We recently bought Liquid Studio 2019 and we are in version 17.1.0.9428.

I made a datamapper to transform XML files to .csv files. For this I used the CSV Writer component. I generate a .csv file by customer number (present in the XML source), the CSV Writer's filename is dynamically generated with the customer number.

When I run the Data Map from the Liquid Studio interface, all lines (from different XML files) that correspond to the same custom are written in the same file (data extracted from clients can come from many different sources ). This is the expected result.

Once I compile the Data Mapper and the .exe application is generated, I run it and realize that there is only the last line written in the client's .csv file. It's like the client file is overwritten and not written in append mode not like the data mapper lauching from the Liquid Studio interface.

Our purpose is to launch automatically the DataTransformationApp.exe witha scheduler.

Why this difference in behavior and how can it be corrected?

Best regards

1 Reply

Reply to Thread
0
Liquid Support Replied
Employee Post Marked As Resolution
Hi,

The output should be identical. Please create a support ticket so we can take a look.

Reply to Thread